Plan Explorer Navigation

The following are the primary features and information about the different tabs found within Plan Explorer. Since the graphical plan diagram in SSMS was used as a starting point for the design of Plan Explorer, some features are compared with the current capabilities of SSMS to illustrate the reasoning behind the feature.

Plan Explorer Menus

File Menu

SentryOne File Menu

CommandDescription
NewCreates a new Plan Explorer Session in a new tab. 
OpenOpens an existing Execution Plan file (.sqlplan | .xml | .queryanalysis | .pesession), deadlock file, or SQL file.
SaveSaves the current file.
Save AsSaves the current file with a new name/new location.
Save AllSaves all files opened in any tabbed sessions.
Recent Files >Displays a list of recently opened files.
ExitExits the program.

View Menu

SentryOne View Menu

CommandDescription
Plan HistoryOpens the Plan History pane.
CommentsOpens the Comments pane.
Start PageOpens the Start Page pane. 
Plan Layout ControlOpens the Layout Editor. Use the Layout Editor to customize the position of the various panes.

Tools Menu

SentryOne Tools Menu

CommandDescription
User PreferencesAllows you to edit the user preferences. 
Edit ConnectionAllows you to edit the server connection. 
Anonymize PlanAllows you to anonymize a .sqlplan. 

Window Menu

SentryOne Window Menu

CommandDescription
FloatAllows the selected panel to detach from the main window rather than being docked.

Note:  This can also be done by dragging the panel by its titlebar.
Close All DocumentsCloses all open query plans. 
Reset Window LayoutResets the windows to the default state.
New Horizontal Tab GroupCreates a new Horizontal tab group with the selected tab.
New Vertical Tab GroupCreates a new Vertical tab group with the selected tab.
Move to Next Tab GroupMoves the selected tab group to the next group.
Move to Previous Tab GroupMoves the selected tab group to the previous group.
1 PlanOpens the desired query plan. 
Windows...Uses the Windows command to manage all your open windows. Uses the Activate command to set focus to the selected window.

Help Menu

SentryOne Help Menu

CommandDescription
Plan Explorer HelpOpens to Plan Explorer in the SentryOne User Guide
Check for UpdatesChecks for the newest version of Plan Explorer.
AboutViews information about Plan Explorer, including build number and number of evaluation days remaining.
End User License AgreementOpens the www.sentryone.com/eula article about licensing information. 

Toolbar

SentryOne Toolbar

ButtonDescription
SentryOne New ButtonNew—Creates a new Plan Explorer Session in a tab.
SentryOne Open Button Open—Opens an existing Session file, Execution Plan, Deadlock, or SQL file,
SentryOne Save Button Save—Saves the current file.
SentryOne Save All Button Save All—Saves all the currently open files.
SentryOne Copy Button Copy—Copies the selected text to the clipboard. 
SentryOne Paste Button Paste—Pastes the selected text from the clipboard.
SentryOne Horizontal Layout ButtonHorizontal Layout—Switches the current tab to a horizontal layout.
SentryOne Vertical Layout ButtonVertical Layout—Switches the current tab to a vertical layout.


ButtonDescription
SentryOne Get Estimated Plan ButtonGenerates an Estimated Plan. (Shortcut Key: CTRL-L)
SentryOne Get Actual Plan ButtonGenerates an Actual Plan. (Shortcut Key: F5 or CTRL-E)

Select the With Live Query Profile option from the drop-down list. A usage chart appears that plots CPU, I/O and waits. 

Note:  Disable the Query Execution warning message with User Preferences (Tools > User Preferences > Warn on actual execution).

SentryOne Show Estimated Plan ButtonToggles the Plan Diagram tab between the Estimated and Actual Plan.
SentryOne Stop ButtonStops the execution of a query. 
SentryOne Edit Connection ButtonEdits the current connection information. 

Command Text

SentryOne Command Text Pane

The Command Text section shows an editable version of the query text for the statement or batch being analyzed. Make changes to the query, then see how this impacts the execution plan by selecting Get Estimated Plan or Get Actual Plan on the toolbar.

When retrieving a plan, you're asked for the server, database, and credentials to connect (unless you launched Plan Explorer from within SSMS using our Management Studio Add-In).

To generate the Actual Plan, the query is run against the target server. By design, the actual query results aren't returned to the Plan Explorer interface. By default, there's a message box explaining this behavior when an Actual Plan is captured.

Note:  Disable the Query Execution warning message with User Preferences (Tools > User Preferences > Warn on actual execution).

If query execution fails, a message displays in the Status bar, located at the bottom of the Plan Explorer window.