BI Documenter

Important:  This is an archive of the help guide for the deprecated product known as BI Documenter. Please upgrade to SentryOne Document for the latest product.

About BI Documenter

BI Documenter is a Microsoft Windows based documentation tool for Microsoft SQL Server with diagramming and template capabilities that includes modules for the following devices :

  • SQL Server relational databases
  • Integration Services packages
  • Analysis Services databases
  • Reporting Services servers
BI Documenter EditionDescription
BI Documenter Database EditionDelivers automated documentation of SQL Server 2005, 2008, and 2012 relational databases.
BI Documenter Standard EditionAdds support for Microsoft SQL Server Analysis Services, Integration Services and Reporting Services.
BI Documenter Professional EditionDelivers all of the functionality of the previous editions, and the ability to create the metabase repository on SQL Server instances, allowing you to share documentation solutions. Professional Edition also gives the ability to use the Compare Snapshot, Object Lineage/Impact Analysis tools.

BI Documenter

System Requirements

The following operating systems are supported by SentryOne BI Documenter: 

  • Windows XP Service Pack 1 or higher
  • Windows 7
  • Windows Vista Ultimate, Business, Home Premium, Home Basic
  • Windows 2008

Note:  Both x86 and x64 OS versions are supported. BI Documenter does not support Windows 8.1 and SQL Server 2014

Software Prerequisites

The following prerequisites are required to use SentryOne BI Documenter :

  • SSIS Runtime Components (Required to document SSIS Packages)
  • SSIS Runtime Components (Required to document SSIS Packages)
  • Microsoft .NET Framework Version 4.0
  • Analysis Services Management Object (AMO - Required to document Analysis Services Objects)
  • SQL Server 2008 Express Edition or Higher

Note:  Even if you are only documenting SQL Server 2005, you are still required to install each of the components listed above.

Installation

Version History

Click here for a PDF file archive of the BI Documenter version history and release notes.

Downloading BI Documenter

This product is deprecated, and is  no longer available for download. If you are interested in documenting the Metadata within your environment, please see SentryOne Document.

How to install BI Documenter

To install SentryOne BI Documenter, complete the following steps: 

Run the setup file BIDocumenterSetup.exe or BIDocumenterSetupFree.exe, and then follow the installation wizard prompts.

Note:  When upgrading an existing version of SentryOne BI Documenter, you must install the upgraded version to the same installation folder you've previously used during installation. The default installation folder is C:\Program Files\Pragmatic Works\BI Documenter.

How to enter your license

Important:  The product must already be registered and you must have your activation code to proceed. Contact sales@sentryone.com to discuss upgrading to SentryOne Document.

Enter your license for BI Documenter by completing the following steps :

  1. Open BI Documenter, and select About. BI Documenter select About
  2. Select Activate Software to open the license window. BI Documenter License window
  3. Select Register to open the registration form, and enter the applicable license information. BI Documenter License window Register
  4. Select Register to continue. Note:  If your license is valid, the Activation window displays.
  5. Select Activate Online now, enter your activation code, and then select Activate to complete your license activation. BI Documenter License window Activate Your Software

Success: The Success window displays if BI Documenter is activated successfully.

Check you have the latest version / Updating your version

There are no more updates available for BI Documenter. Please email sales@sentryone.com for information about documenting your environment with SentryOne Document.

If you are interested in upgrading your BI Documenter software to the new SentryOne Document, where you can document all of the SQL Server, SSIS, SSAS, SSRS, Hive, Tableau, Power BI,  Excel,  and Custom Metadata import, items within your environment, see SentryOne Document

Solutions

Creating a New Solution

A solution is a collection of related objects that you want to view as a single system for the purposes of documentation. Create a new solution in BI Documenter by completing the following steps :

  1. Select Add a New Solution to create a new solution. BI Documenter Add a New solution
  2. Enter a name and description for the solution, and then select Create Solution to create the solution. BI Documenter Add New Solution window

Note:  Creating a Solution, and adding solution items to that solution is quick and easy in SentryOne Document. For more information about creating a new solution in SentryOne Document, see the Solutions article.

Adding a SQL Server Database

Add a SQL Sever Database to your BI Documenter solution by completing the following steps :

  1. Select Add SQL Server Database from the Review your Solution step. BI Documenter Add SQL Server Database
  2. Enter the Server name for your SQL Server.
  3. Enter the authentication credentials, and then select Connect.
  4. Choose the database you want to add, and then select Next. BI Documenter Add SQL Server Database Step 1
  5. Review the name and enter a description. Select Finish to add the SQL Server Database.

Note:  Ensure that all of the items within your environment are documented with SentryOne Document. To see all the object types you can document, and to see how easy it is to begin documenting them, see the Solution Items article.

Adding an Analysis Services Database

Note:  Only BI Documenter Professional edition supports this feature.

Add an Analysis Services database to your BI Documenter solution by completing the following steps :

  1. Select Add Analysis Services Database from the Review your Solution step. BI Documenter Add Analysis Services Database
  2. Enter the Server name for your Analysis Services database.
  3. Enter the authentication credentials, and then select Connect.
  4. Choose the database you want to add, and then select Next. BI Documenter Add Analysis Services Database Step 1
  5. Review the name and enter a description. Select Finish to add the Analysis Services Database.

Note:  Ensure that all of the items within your environment are documented with SentryOne Document. To see all the object types you can document, and to see how easy it is to begin documenting them, see the Solution Items article.

Adding an Integration Services Package

Note:  Only BI Documenter Professional edition supports this feature.

Add an Integration Services package to your BI Documenter solution by completing the following steps :

  1. Select Add Integration Services Package from the Review your Solution step. BI Documenter Add Integration Services Package
  2. Select the package location. BI Documenter Add Integration Services Package Step 1
  3. Select the Package Store. Select Server if Server / SSIS Package Store is selected.
  4. Enter the Package Path, and then select Next.
  5. Select the checkbox(es) for the packages that will be imported. Enter individual passwords for each package, or Select Apply password to All Packages to assign a password to all packages. BI Documenter Add Integration Services Package Step 2
  6. Select Finish to add the Integration Services package.

Note:  Ensure that all of the items within your environment are documented with SentryOne Document. To see all the object types you can document, and to see how easy it is to begin documenting them, see the Solution Items article.

Adding a Reporting Services Server

Note:  Only BI Documenter Professional edition supports this feature.

Add a Reporting Services server to your BI Documenter solution by completing the following steps :

  1. Select the Add Reporting Services Server from the Review your Solution step. BI Documenter Add Reporting Services Server
  2. Enter the server name.
  3. Select the Server Mode. Note:  Native is the default.
  4. Enter the Report Server Name or IP.
  5. Enter the Web Service Directory. Note:  This is /ReportServer by default, only change if you know the location has been changed from the default. As you change the "Report Server Name or IP" and "Web Service Directory" the web service link at the bottom of the screen will change. Use this link to verify the ReportService2005.asmx exists on your reporting server.
  6. Enter the folder you want to snapshot. Note:  To snapshot the entire server enter:  . To snapshot an individual folder enter the folder path:  /SampleReports.
  7. Enter the Authentication Credential, and then select next. BI Documenter Add Reporting Services Server Step 1
  8. Review the name and enter a description, and then select Finish.

Note:  Ensure that all of the items within your environment are documented with SentryOne Document. To see all the object types you can document, and to see how easy it is to begin documenting them, see the Solution Items article.

Deleting Unwanted Snapshots

To delete any Snapshots within BI Documenter, complete the following steps:

  1. Select Manage Snapshots from the Review your Solution step. BI Documenter Manage Snapshots
  2. Select a snapshot to delete or delete all snapshots for a solution. BI Documenter Manage Snapshots for Solution

Note:  Snapshots taken within the last 24 hours are marked with a star.

Producing Documentation

Creating a Snapshot

A snapshot is a record of all the objects in your solution at a moment in time and is used as the source data for your documentation. You can delete unwanted snapshots using the Snapshot Management Tool. Create a snapshot for your BI Documenter solution by completing the following steps :

  1. Create or open an existing solution. Choose your solution and then select Next. BI Documenter Open Solution
  2. Review your solution to add any objects you require, and then select Next to continue.
  3. Enter a name and description for this snapshot. BI Documenter Create a Snapshot
  4. Choose any Filters and Options that will be used when creating the snapshot, and then select Next. Note:  To understand how to use filters see Filtering Objects Before Snapshot. To see the options available see Before Snapshot Options.
  5. Once the snapshot is complete select Next to go to the produce documentation step.

Snapshot Options

There are several options available when creating a snapshot that can save processing time or give you the detailed representation of your objects.

BI Documenter Create a Snapshot Options

SQL Server Options

OptionDescription
 Generate table profile data Snapshot will include statistics including %null, %unique, min value and max value.
 Include object dependenciesSnapshot will include all dependencies of each object.
 Include column level mappingsSnapshot will include all column level mappings.
 Generate sample data Snapshot will randomly select ten rows of data and include it in the snapshot.
 Generate DDL scripts Snapshot will include all scripts used to create the objects. This is needed for the Snapshot Compare feature.

Integration Services Options

OptionDescription
 Save package definition (*.dtsx) Snapshot will include the dtsx file for each package. 

Reporting Services Options

OptionDescription
 Save report defintion (*.rdl) Snapshot will include the rdl for each report,

Analysis Service Options

OptionDescription
 Save database definition (*.xmla)

Producing Documentation

Creating documentation consists of a two-part process:

  • Collect the source data by making a snapshot.
  • Creating the documentation file.

Create documentation for your BI Documenter solution by completing the following steps :

  1. Create a Snapshot or open an existing snapshot. Go to the Select the Documentation Source Data step by doing one of the following :
    • selecting Next after creating a new snapshot
    • selecting the Use Existing Snapshot link from the Create a Snapshot step. BI Documenter Select the Documentation
  2. Select the snapshot you want to use as the source data for this documentation.
  3. Uncheck any objects from the snapshot that you would like to exclude from this documentation and then select Next to continue.
  4. Select the output format and location. BI Documenter Finalize Document Output
  5. Design your custom template if required and create any necessary diagrams.
  6. Add any required documents and images, and filter out any unwanted objects.
  7. Select Next to open the progress screen, and then select Finish to return to the solutions home and open your documentation if Open documentation when finished is checked. BI Documenter Producing Documentation

Note:  Generate documentation for more object types, and in more output formats with SentryOne Document. Learn more at Generating Documentation.

Choosing the Output Format

There are two output formats to choose from in BI Documenter :

  • Compiled HTML Help. Microsoft Compiled Help format (*.chm), a self-contained format that is suitable for email distribution.

Note:  When sending CHM files by email, first zip the file because some email clients ( Microsoft Outlook) block attachments with the *.CHM file extension.

  • HTML Files. Standard, portable HTML, suitable for deployment on a web server.

Note:  Carefully consider the location of the HTML file output. On larger solutions thousands of HTML files may be generated.

Select the required output format on the Finalize Document step.

BI Documenter Finalize Document Output format

Note:  Generate documentation for more object types, and in more output formats with SentryOne Document. Learn more at Generating Documentation

Choosing the Output Location

You must specify the output location for the documentation on the Finalize Document step.

If you select Compiled HTML Help you must select the … (ellipsis) button and specify the location and filename.

If you select HTML files you must select the …(ellipsis) button and specify the location.


BI Documenter Finalize Document Output file location

Custom Template Design

Note:  Only the BI Documenter Database and Professional editions support this feature.

BI Documenter features a template system that you can use to customize the design of your documentation. Each solution can have it's own template design.

To design a template select the Template tab on the Finalize Document step.

FeatureDescription
ColorChange the color to your desired colors by selecting from the Color dialog (,,, button) or selecting Hex and entering a HEX value.
LogoAdd a custom logo by selecting Browse and choosing the desired image.
PreviewPreview the template design by selecting Preview.
Restore DefaultsRestore the default design by selecting Restore Defaults.


BI Documenter Finalize Document Template 

Filtering Output by Object Type

Note:  Only the BI Documenter Database and Professional editions support this feature.

You can filter objects out of the documentation.  Each solution has it's own filter settings. Filter Database objects for your BI Documenter solution by completing the following steps :

Object TypeDescriptionImage
SQL Database ObjectsSelect the Database Objects tab of the Finalize Document step to filter SQL Database objects.BI Documenter Finalize Document Database Objects filter
SSAS Database ObjectsSelect the Analysis Objects tab of the Finalize Document step to filter SSAS Database objects.BI Documenter Finalize Document Analysis Objects Filter
SSIS Package ObjectsSelect the Integration Objects tab of the Finalize Document step to filter SSIS Package objects.BI Documenter Finalize Document Integration Objects Filter
SSRS Server ObjectsSelect the Integration Objects tab of the Finalize Document step To filter SSRS Server objects.BI Documenter Finalize Document Reporting Objects Filter

Note:  SentryOne Document allows you to create custom filters for your solutions. Learn more about filtering in SentryOne Document at Solution Items.

Compiled Help Text Encoding

Change the text encoding that's used when creating the CHM file by completing the following steps :

  1. Select Options from the main window. BI Documenter Review your Solution Options
  2. Select the Output tab and choose your required encoding from the following :
  •  ASCII (recommended for English documentation).
  • Unicode (recommended for extended character support).

BI Documenter Options Output

Note:  Unicode encoding increases the time taken to compile documentation. 

Diagramming

Creating a New Diagram

Note:  Only the BI Documenter Database and Professional editions support this feature.

BI Documenter features a built-in diagram editor that you can use to document  your solutions. The diagram tool features a data-driven palette of objects to assist you in graphically conveying your Business Intelligence architecture. Add a new diagram by completing the following steps :

  1. Select the Diagrams tab of the Finalize Document step.
  2. Select New Diagram to create a new diagram and launch the diagram editor.

BI Documenter Finalize Document Diagrams 

Using the Diagram Editor

Note:  Only the BI Documenter Database and Professional editions support this feature.

BI Documenter features a built-in diagram editor that you can use to document your solutions. The diagram tool features a data-driven palette of objects to assist you in graphically conveying your Business Intelligence architecture. To begin using the Diagram editor, you must create a diagram. See Creating a diagram for more information. 

Adding objects to the diagram

Add objects to the diagram by selecting the required object in the left-hand-side palette and dragging the object to the desired location, or selecting Add Object on the toolbar.

Removing objects from the diagram

Remove objects by doing one of the following :

  • selecting the objects and then selecting Delete on the keyboard 
  • selecting the objects and then selecting Remove on the toolbar.

BI Documenter Diagram Editor

Drawing connecting lines between objects

To draw a connecting line between two objects select Add Connector on the toolbar so that it toggles to a highlighted state. Select and hold the left mouse button over the first object and then drag the mouse to the second object and release the left mouse button. If you do not want to draw any more connecting lines toggle the Add Connector toolbar button.

Note:  The Hide/Show Palette button as well as the Zoom button on the Diagram Editor toolbar can be used to add more room on larger diagrams.

Setting the zoom

To change the zoom use the drop down list on the toolbar.

Changing background colors

To change the font or background right click an object and then select Change Background Color.

Adding text to shapes and changing fonts

  • To add text to a shape, right click the shape and select Add Text
  • To edit the text right click the shape and select Edit Text.
  • To change the font right click a shape and select Font.

Using the Diagram Editor Object Property Tab

Note:  Only the BI Documenter Database and Professional editions support this feature.

BI Documenter Diagram Editor Object Property tab

Exporting your Diagram as an Image

Note:  Only the BI Documenter Database and Professional editions support this feature.

BI Documenter is able to export your diagrams into a variety of commonly used image formats.

To export a diagram, select the Export on the diagram editor toolbar.

You can export your diagram in the following formats :

File Description
JPEGAn easily compressed graphics format that displays photographic as well as graphic images.
GIFA low resolution graphics format suited to line drawing.
PNGA compressed image file format similar to JPEG.

BI Documenter Exported Diagram example

Documents And Images

How to Add a Document

Note:  Only the BI Documenter Database and Professional editions support this feature.

BI Documenter allows you to add your existing documentation as attachments to your documentation set. You can include your own files and documents in the documentation by completing the following steps :  

  1. To add a file or document select the Files tab on the Finalize Document step.
  2. Select Add Document and then browse for the required file. BI Documenter Finalize Document Files tab

 Rename the filename used in the documentation select the Rename button.

How to Add an Image

Note:  Only the BI Documenter Database and Professional editions support this feature.

BI Documenter allows you to add your existing images to your documentation set. Add existing images by completing the following steps :

  1. Select the Files tab on the Finalize Document step.
  2. Select Add Image and then browse for the required image. BI Documenter Finalize Document Files tab To rename the filename used in the documentation select the Rename button.

Object Lineage/Impact Analysis

Use Object Lineage / Lineage Analysis for your BI Documenter solution by completing the following steps :

  1. Select Impact Analysis/Object Lineage from the main form or Tools pane on the Review your Solution screen. BI Documenter Review your Solution Impact Analysis/Object Lineage
  2. Right click and select Render as Diagram or Render as List. BI Documenter Impact Analysis Render as Diagram

Render as Diagram will draw the selected tree node object and the objects that will possibly be impacted by a change to the selected context in the right hand pane canvas view.

BI Documenter Object Lineage Render as Diagram example

Render as List will produce a tree list of impacted objects.

BI Documenter Object Lineage Render as List example

3. Select Save to save the view as part of the documentation or as an image file to the file system.

Note:  Several layout options are available through the Graph Layout toolbar option. A filter option is available to remove non-essential objects from the right pane canvas view.

Snapshots

Comparing Snapshots

BI Documenter has a utility that allows you to see the difference between two snapshots. Compare snapshots by completing the following steps :

  1. Select Compare Snapshots on the main form to open the UI for the snapshot. BI Documenter Compare Snapshots
  2. Select two snapshots to compare to enable the Start Compare button.
BI Documenter Compare Snapshots select Solution
BI Documenter Compare Snapshots Solution 2

Note:  The current solution on the main form is set to select for each Solution drop down. by default. Compare snapshots from different solutions by changing the Solution drop down in either Snapshot 1 or Snapshot 2. If a new solution is selected the snapshots for the selected solution  appear in the Snapshot drop down below it.

3. Selected BI Documenter Start Compare button to begin comparing the snapshots. While the snapshot compare is being performed, you can stop processing at anytime by selectingBI Documenter Cancel button button which is next to the BI Documenter Start Compare buttonbutton.

Understanding Snapshot Results

Snapshot Compare makes it easy to see what objects have been modified, added or deleted between two snapshots.

Results Grid

After a snapshot compare has been performed the first thing to look at is the results grid. Any colored items indicate a change has occurred somewhere in one of the snapshots. In the screenshot below we see that AdventureWorks SQL Server, Tables and Stored Procedures have changes in them.

BI Documenter Snapshot Results Grid

Select on child objects to see the changes to individual objects. BI Documenter Snapshot Results Grid expanded

Icons and Color Highlighting Legend

The following legend explains the colors and icons of the results grid :

IconDescription
BI Documenter Right Arrow iconObject was modified in snapshot 2. Items will be highlighted in Green.
BI Documenter Left Arrow iconObject was modified in snapshot 1. Items will be highlighted in Green .
BI Documenter Double blue arrow iconObject existed in snapshot 1 but does not exist in snapshot 2. Items will be highlighted in Pink.
BI Documenter Double yellow arrow iconObject existed in snapshot 2 but does not exist in snapshot 1. Items will be highlighted in Light Gray.
BI Documenter Equal icon Object are equal in both snapshots.
BI Documenter Not Equal iconObjects are not equal in both snapshots. Changes made in both snapshots. Items will be highlighted in Green.

Note:  Any top level grid items such as server names, object types, SSIS packages, etc only show BI Documenter Equal icon or BI Documenter Not Equal icon to indicate whether changes have been found in the snapshots. Top level items that have changes will be highlighted in Green.          

Comparison Window

To see the changes in the objects, select the object in the results grid to populate the changes in the comparison window. There are two modes where differences display : Text Mode and Property Mode.

Text Mode

In text mode the differences in the script are shown in color coded, side-by-side windows. Any differences in the text of the object appear in the window. (See Color Coding legend below) . BI Documenter Snapshot Results Text Mode

ButtonDescription
Copy Source The option to copy the current script in the comparison window is available by selecting Copy Source at the top of the comparison window .
Format Script before compareSelecting this option will "prettify" a script before it is compared. This is particularly useful for script with very long lines of code that make it difficult to read the differences in the comparison window. For instance the following statement: select column1, column2, column3, column4, column5, column6, column7, column8, column9, column10 from dbo.Table Will be formatted as : selectcolumn1,column2,column3,column4,column5,column6,column7,column8,column9,column10fromdbo.Table This makes the differences easily recognizable on a granular level.

Property Mode

In property mode the properties of an object are compared in side-by-side windows with the difference highlighted.

BI Documenter Snapshot Compare Results Property Mode

Color Coding

ColorMeaning
Green The line of code or property value has changed.
Light Grey The line of code is present in the second script but not the first or vice versa.
Pink The line of code has been removed in the second script.

Using the Compare Filter Options

Snapshot Compare allows the use of filters to make it  easier to find the exact differences you're searching for.

Filtering Options

There are two subsets of filtering options. Both can be used before and after a snapshot is compared. Filtering items by status :

BI Documenter Filter Compared Objects

Selecting and unselecting the above status checkboxes causes the snapshot results to display or hide items in the respective status. For example, the snapshot image below shows that uspUpdateEmployeePersonalInfo has been modified in aw snapshot 4.

BI Documenter Compare Snapshots example

After the Modified checkbox is unselected, uspUpdateEmployeePersonalInfo no longer appears in the results view.

BI Documenter Compare Snapshots example

Note:  Re-selecting the Modified checkbox makes uspUpdateEmployeePersonalInfo reappear.

Filtering Statuses

There are five statuses that can be used to filter items in the snapshot compare.

Status Description
Modified The object has been modified in on of the snapshots. The  icon in the middle of the object name explains which object  changed. BI Documenter Right arrow icon  indicates  the object changed in Snapshot 2.BI Documenter Left arrow iconindicates the object changed in Snapshot 1.
New The object is new in Snapshot 2. Also indicated by the BI Documenter Double Yellow arrow icon  icon.
Deleted The object existed  in Snapshot 1, but not Snapshot 2. Also indicated by the BI Documenter Double blue arrow icon  icon.
Not Equal The object changed from Snapshot 1 to Snapshot 2.
Equal The objects are the same.

Object Filters

Snapshot compare allows the use of object filters to filter out types of objects before and after a snapshot. To filter out an object simply uncheck the checkbox next to an object name. When an object is unchecked it will appear in bold red text to indicate the filter has been set.

BI Documenter Compare These Objects Filter

Selecting / unselecting an object with child objects will select/unselect all of its child nodes as well. Below, SQL Server was unselected and all of the child items were unselected.

BI Documenter Compare These Objects Filtered items

Pre Comparison Object Filtering

Using an object filter before a snapshot is performed prevents the snapshot from comparing the filtered objects. If there are object types you do not want to be compared then unselect the objects before performing a snapshot compare. This is useful if the snapshot contains objects that will take a large amount of time to be compared when the comparison of those objects is unnecessary.

Post Comparison Object Filtering

Using an object filter after a snapshot is performed simply hides in the results view. For instance in the screenshots below the stored procedures are visible in the first screenshot but not visible after the stored procedure filter option is unselected.

BI Documenter Snapshot Compare Stored Procedures visible example
Stored Procedures Visible

BI Documenter Snapshot Compare Stored Procedures hidden example
Stored Procedures hidden

Note:  SentryOne Document allows you to create custom filters for your solutions. Learn more about filtering in SentryOne Document at Solution Items.

Filtering Objects Before Snapshot

You can filter objects out of the snapshot using the Filters Tab. 

BI Documenter Create a Snapshot Filter tab

There are two options for filter objects :

  • Filter by Object Type
  • Filter by Object Name

Filter by Object Type

In the Filter By Object Type option unselect the object types that you do not want to be included in the snapshot. Once an item is unselected it will turn bold red to indicate a filter has been set. BI Documenter Create a Snapshot Filter by Object Type

Filter by Object Name

Note:  This option is available only for SQL Server Objects

In the Filter By Object Name option you have the ability to filter objects by name. There are two options for filtering objects by name:

Filter Object

In this option you select an object type to filter (Table, Stored Procedure) in the treelist. After you select on an object type, a list of objects displays in the Filter Object tab. You can now go through and select the individual items you want excluded from the snapshot. BI Documenter Create a Snapshot Filter by Object Name Filter Objects

Filter Matches

In this option you can exclude or only include items by name or by matching patterns (starts with, ends with and contains).

BI Documenter Create a Snapshot Filter by Object Name Filter Matches

Use Filter Matches by completing the following steps:

  1. Select the Action (Exclude These Objects, Include Only These Objects).
  2. Select the type of match (equals, starts with, ends with or contains).
  3. Enter the text of the filter, and then select Add Filter

Once a filter is added it shows up in the list below the Add Filter button. Edit the filter by selectingBI Documenter Edit Filter button and then edit the details of the filter. Select Update Filter to save your changes to the filter. Delete a filter by selecting BI Documenter Delete Filter button.

Note:  Once filters have been added to your solution the Filters tab will be highlighted in Red or Yellow as a reminder in future snapshots that Filters are set. BI Documenter Create a Snapshot Filter set

Note:  SentryOne Document allows you to create custom filters for your solutions. Learn more about filtering in SentryOne Document at Solution Items.

Using the Command Line Application

BI Documenter has a command line application that lets you update or create documentation on a schedule.

Executing the Command Line Application

BI Documenter provides a console application, BIDOC.exe that can be used to automate the production of documentation on a schedule by using a existing BIDocumenter Solution (Stored in SQL CE or SQL Server Metabase) and optionally outputs documentation after snapshot to CHM or HTML format.To do this you need to run BIDOC.exe (which is located in the BI Documenter application directory) as a Windows scheduled task. BI Documenter also in includes a screen to assist you in creating the command line information.

BI Documenter Schedule Snapshot Command Line

Command Line Syntax

Profesional Edition(SQL Server Metabase)
Syntax: BIDOC.EXE /SOLUTION "<solutionname>" /SERVER "<servername>" /METABASE "<metabase name>" [/USER "<username>"] [/PWD "<username>"] [/NOOUT] [/CHM [/OVERWRITE] | /HTML] [/OUT "<output file/folder path>" [/FILESUFFIX "<pattern>"]] [/WAIT] [/LOG "<log file path>" [/LOGSUFFIX "<pattern>"]] [/HELP]
 
Database or Standard Edition
Syntax: BIDOC.EXE /SOLUTION "<solutionname>" [/NOOUT] [/CHM [/OVERWRITE] | /HTML] [/OUT "<output file/folder path>" [/FILESUFFIX "<pattern>"]] [/WAIT] [/LOG "<log file path>" [/LOGSUFFIX "<pattern>"]] [/HELP]

Important:   

  • All switches can be used in one of the following ways. For example, -HELP , /HELP , HELP
  • All switches are case-insensitive.
  • Value must be placed in double quotes if you have space in the value otherwise double quotes are optional. For example,  VALID => /OUT "C:\My Doc"  INVALID => /OUT C:\My Doc SWITCHES
Command line SwitchDescription
/SOLUTION < solution name >Solution name that you want to process.
/SERVER < server name > Server name where BIDoc Metabase is stored (ignored when using Database or Standard Edition).
/USER < userid >User name to connect SQL Server. If user name is blank them Windows Authentication is used (ignored when using Database or Standard Edition).
/PWD < password >Password for specified userid to connect SQL Server. If user name is blank them Windows Authentication is used (authentication is ignored when using Database or Standard Edition)
/METABASE < database name >BIDoc repository name (i.e Database Name) where Documentation is stored (ignored when using Database or Standard Edition)
/OUT < output path >Output file name or folder. If output format is CHM then has to be existing or non-existing file name (use /OVERWRITE to overwrite existing file). If output format is HTML then it has be an existing folder name.
/FILESUFFIX < pattern > Appends current timestamp with a specified datetime pattern to the output file. For example,  if FILESUFFIX is MMddyyyy then output file name may look like AdventureWorks_12312009.chm
/LOG < pattern > Log file path where process information is stored .
/LOGSUFFIX < pattern > Appends current timestamp with a specified datetime pattern to the log file. For example, if LOGSUFFIX is MMddyyyy then log file name may look like LOG_AdventureWorks_12312009.txt
/HELP or /? Displays usage help.
/CHMOutput format as Compiled Help File (CHM).
/HTMLOutput format as html.
/NOOUT Only perform snapshot and skip help file generation.
/OVERWRITEOverwrite output file if already exists (Only valid if /CHM is specified).
/WAITWait for user input before closing the command window after process is completed.
/SQLCE Use this flag to test commandline to process snapshot stored in SQLCE Database for Trial version. (not valid for registered version).

Examples

Example-1 : Perform snapshot using windows authentication to connect to metabase and output documentation to CHM file


BIDOC.EXE /SOLUTION AdventureWorks /SERVER DEV001 /METABASE "BIDocumenter" /CHM /OUT "C:\My Docs\AdventureWorks.chm"

Example-2 : Perform snapshot using mixed mode authentication to connect to metabase and output documentation to CHM file


BIDOC.EXE /SOLUTION AdventureWorks /SERVER DEV001 /USER sa /PASSWORD /METABASE BIDocumenter /CHM /OUT "C:\My Docs\AdventureWorks.chm" 

Example-3 : Overwrite target file if exists


BIDOC.EXE /SOLUTION AdventureWorks /SERVER DEV001 /METABASE BIDocumenter /CHM /OUT "C:\My Docs\AdventureWorks.chm" /OVERWRITE 

Example-4 : Use timestamp suffix in the output file and log file


BIDOC.EXE /SOLUTION AdventureWorks /SERVER DEV001 /METABASE BIDocumenter /CHM /OUT "C:\My Docs\AdventureWorks.chm" /OVERWRITE /FILESUFFIX "MMddyyyy" /LOG "C:\My Docs\Log\AdventureWorks_LOG.txt" /LOGSUFFIX "MMddyyyy" 

Example-5 : Only perform snapshot but skip help file generation


BIDOC.EXE /SOLUTION "AdventureWorks" /SERVER "DEV001" /METABASE "BIDocumenter" /NOOUT 

Example-6 : For Database/Standard Edition or when Snapshot is stored in SQLCE


BIDOC.EXE /SOLUTION "AdventureWorks" /CHM /OUT "C:\My Docs\AdventureWorks.chm" 

Example-7 : Display help


BIDOC.EXE /HELP 

Example-8 : Dont close command window after process is completed


BIDOC.EXE /SOLUTION AdventureWorks /SERVER DEV001 /METABASE BIDocumenter /CHM /OUT "C:\My Docs\AdventureWorks.chm" /WAIT 

Example-9 : Evaluate commadline for SQLCE Database during trial version


BIDOC.EXE /SOLUTION AdventureWorks /SQLCE /CHM /OUT "C:\My Docs\AdventureWorks.chm" /WAIT

Documentation Features

SQL Server Features

SQL Server Documentation Features include performance recommendations, relationship linking, full DDL scripts and more.

Feature and DescriptionImage

Documented Items


The following is a screenshot of the main objects that are documented for a SQL Server database :
BI Documenter SQL Server Documented items

Full DDL Scripts


BI Documenter captures the full DDL scripts required to recreate an object.
BI Documenter SQL Server Full DDL Scripts

Object Dependencies


Both parent and child object dependencies are easily viewable within the documentation.
BI Documenter SQL Server Object Dependencies

Recommendations


The recommendations feature for SQL Server database was developed by SQL Server MVP's to alert BI Documenter users of potential performance issues. The list of recommendations include database level settings, missing primary keys, missing clustered indexes and more. The screenshot below illustrates a sample of the recommendations that can be made for Profile Dataa database.
BI Documenter SQL Server Recommendations

Profile Data


Profile data allows you to see statistical data for each column (where applicable) in a table. Current profile data includes %null, min value, max value and %unique.
BI Documenter SQL Server Profile Data

Row Count and Table Description


You can easily check table row count and description in tabular way when you highlight Tables node in the CHM help file.

Sample Data


Sample data gives you a random selection of 10 rows of data from a table.
BI Documenter SQL Server Sample Data

SSIS Features

SSIS Documentation features include performance recommendations, workflow images, granular level documentation of all executables and more. 

Feature and DescriptionImage

Documented Items


BI Documenter will document package executables, connection managers, variables and configurations along with the full source (dtsx) of an SSIS package.
BI Documenter SSIS Documented Items

Recommendations


The recommendations feature for SSIS was developed by SQL Server MVP's to alert BI Documenter users of potential performance issues within their SSIS packages.
BI Documenter SSIS Recommendations

Control Flow Diagram


BI Documenter will capture the workflow for a package and store it as an image. This makes it very easy to refer to the documentation at a later date to review changes that have been made since the documentation was produced. Control Flow Diagram lists the following items :
  • Tasks
  • Variables
  • Connections
  • Precedence Constraints
  • Expression on Variables (Red circle on variable icon)
  • Expression on Tasks (Red circle on task icon)
  • Expression on Connection (Red circle on connection icon)
BI Documenter SSIS Control Flow Diagram

Data Flow Diagram


SSIS Package documentation also captures individual dataflow screenshots so you can visually see the steps inside dataflow just like you can see in SSIS Package Designer (DataFlow Tab). Data Flow Diagram lists the following items :
  • Components
  • Paths
  • Path Names (Only in certain cases e.g. Conditional Split, SCD Transform)
BI Documenter SSIS Data Flow Diagram

Column Mappings


SSIS Documentation lists column mappings for each components inside dataflow so you can easily see mapped and unmapped columns for each components.
BI Documenter SSIS Column Mappings

Reporting Services Documentation Features

Reporting Services Documentation Features include granular level documentation of report objects, full RDL and more.

Feature and DescriptionImage

Documented Items


Below is a screenshot of the main objects that are documented for a Reporting Services Server along with a view of reports and data sources.
BI Documenter SSRS Documented Items

Granular Level Object Documentation


BI Documenter will document all of the objects of a report in a very granular level.
BI Documenter SSRS Granular Level Object Documentation

Full RDL


The full RDL is stored in documentation. This allows the recreation of a report with relative ease in the event of a report is lost or damaged.
BI Documenter SSRS Full RDL

Analysis Services Documentation Features

Analysis Services Documentation Features include granular level documentation of analysis objects, full XMLA and more.

Feature and DescriptionImage

Documented Items


The following is a screenshot of the objects that are documented for a Analysis Services Server
BI Documenter SSAS Documented Items

Full XMLA


The full XMLA is stored in documentation.  

BI Documenter SSAS Full XMLA